Q1183110600

Hi3520DV300平台Linux内核3.10.y应用AR1021模块驱动包

0
阅读(75) 评论(0)

应用Hi3520DV300平台

Linux操作系统,Kernel:3.10.y版本的方案,在选择使用USB接口AR1021X模块时,编译加载时,有很多咨询,其实,真丢不同的kernel版本,有针对性的驱动包


同时提示:

3.10驱动要以下三个ko 


compat.ko


cfg80211.ko (不能用内核的cfg80211.ko,要用驱动的)


ath6kl_usb.ko




而象Kernel 4.9的,只要按照以下驱动编译说明方法,一个ath6kl_usb.ko就可以


设置build/x86/config.x86文件里面的编译环境,然后在build目录下执行make BOARD_TYPE=x86


我们的驱动放到内核外,把内核路径和交叉工具设置好,直接去build目录编译就ok


4.9上编译出来就ath6kl_usb.ko



内核的cfg80211配置为M,testmode选项配置为y


去build目录执行make BOARD_TYPE=x86




这种一定要结合相互吻合的Kernel版本起来才性,

如果是做soft ap,还具体牵涉到hostapd工具版本,用开源的2.0以上的版本,驱动里面也有一套。3.10以内的驱动,在kernel4.9的  可以考虑就用开源的2.0以上的版本


以上观点由纳拓科技分享!请勿随意复制、编辑转用!