bigbaicai

文章转自一牛网论坛 一牛网旗下拥有一牛网论坛、一牛网元器件商城、一牛网技术众包平台等一系列服务于广大工程师的平台,让研发更快、更便捷!

更新GMS包时编译报错"already defined by "

0
阅读(69) 评论(0)

[DESCRIPTION]

更新升级GMS版本时,编译报错”……already defined by…… “的解决办法

[SOLUTION]

GMS4.2版本更新时,可能会有一些lib库和系统原来的lib文件命名一致,导致冲突
参考如下办法解决:
NOTE: Please rename the below libraries to avoid build conflicts with GMS
libraries:
Frameworks/support/renderscript/v8/rs_support/android.mk: libRSSupport ->
libRSSupport_old (2 places)
frameworks/support/renderscript/v8/jni/Android.mk: librsjni ->
librsjni_old and libRSSupport -> libRSSupport_old (2 places)
and if you include GMS GalleryGoogle.apk (otherwise do not rename the
below libraries):
packages/apps/Camera/jni/Android.mk: libjni_mosaic -> libjni_mosaic_old
packages/apps/Gallery2/jni/Android.mk: libjni_filtershow_filters ->
libjni_filtershow_filters_old
packages/apps/Gallery2/jni/Android.mk: libjni_eglfence ->
libjni_eglfence_old