crazybird

【原创】令新手头疼的modelsim库编译

1
阅读(8997) 评论(7)

    估计很多人买了CB哥的书来看吧,他们在学习modelsim仿真的过程中可能遇到过明明是按照书上的步骤添加器件库的了,但还是出现如下的错误:

仿真出错

    首先,我想说的是CB哥书上的modelsim-altera10.1d是随QuartusII一起安装的,它已经编译了altera的器件库。它是一个免费版的仿真工具,不需要破解,当然它的功能不是最强大的,仿真速度也不是最快的,但已经可以满足我们一般的仿真了。有些人可能装了速度较快的SE版本的不带altera器件库的modelsim,这时器件库的问题就来了,尤其是那些新手。为了搞定上图的错误,在这里给出了一种解决办法,希望对大家有所帮助。

(1)在我们的设计中经常会用到宏定义模块,这是就需要我们添加altera器件库,其中必要的编译资源文件有quartusII安装目录/eda/sim_lib下的220model.v和altera_mf.v(以Verilog描述电路),另外还常用到PLL,因此还要目标器件库,如quartusII安装目录/eda/sim_lib下的cycloneive_atoms.v等。接下来,让我们开始编译我们指定的器件库。以上一篇博文安装的modelsim se 6.5g来进行库的编译,首先在modelsim的安装目录下新建altera文件。

编译正确

(2)启动modelsim仿真软件,点击“File”--->“Change Directory…”,在弹出的对话框中选择刚刚在modelsim安装目录下新建的altera文件,点击“确定”。

lujing

(3)点击“File”--->“New”--->”Library…”,输入库的名字:220model以新建一个库,点击“OK”。

新建库

(4)点击“Compile”--->”Compile…”,在弹出的对话框中,选Library为刚刚新建的220model,查找范围为quartusII安装目录/eda/sim_lib,选择220model.v,然后点击“Compile”,“Done”。

编译库1

(5)同理,在altera文件下新建库文件altera_mf和cycloneive_atoms,然后将quartusII安装目录/eda/sim_lib下的编译资源文件altera_mf.v和cycloneive_atoms.v编译到相应的库文件。

新建库1

新建库2

新建库3

新建库4

(6)接着将上面编译的库添加到modelsim.ini文件中。右击modelsim安装目录下的modelsim.ini文件,选择“属性”,去掉只读。

配置1

去掉只读

(7)打开modelsim.ini文件,添加如下内容,然后关闭文件,并加上只读属性。

添加1

只读

(8)以后打开modelsim,都可以看到我们添加的库。

库

(9)接下来,以CB哥的Sobel边缘检测例程为例进行仿真,看是否还出现之前的错误。打开modelsim工程,点击“Compile”--->”Compile All”,结果出现以下问题:

找不到文件1

(10)根据错误提示可知,找不到源文件,原因是我改变了modelsim工程的路径,从而无法找到源文件。解决方法是将工程中的源文件删掉(切不可勾选从磁盘中删除),重新加载源文件。

删除源文件

删除源文件1

添加源文件1

添加源文件2

(11)从新全编译源文件,发现编译都通过。

编译通过1

(12)点击“Simulate”--->”Start Simulation…”,由于本设计中使用了Shift_RAM和PLL,需在Libraries选项卡下添加搜索库220model、altera_mf和cycloneive_atoms。

搜索库1

搜索库2

(13)切换到Design选项卡,展开库work,选中Video_Image_Processor_TB,点击“OK”开始仿真。

仿真1

(14)结果发现没有信号出来,由编译信息可以设计被优化了。

优化1

(15)解决的办法是将modelsim.ini文件的“VoptFlow = 1”改为“VoptFlow = 0”(修改之前记得把modelsim.ini属性去掉,修改完后把只读改回来)。

解决优化

(16)有时还会出现下面的问题,我个人的解决方法是重新建立工程,不知大家是否有更好的办法(希望互相告知)。

重建工程

(17)重建工程后,再进行仿真就大功告成了。

成功

    我晕,现在已经凌晨2:30了,今早8:30还要实习呢!该睡了,88,晚安*^_^*


    补充:如果第(15)点改的是当前工程下的modelsim.ini文件,就不会出现第(16)点的问题;或者通过菜单Simulate——>Start Simulate,然后将“Enable Optimization”的钩钩去掉也可解决该问题。


































 

  1. @Bless_Bigo   

    写得真好!我一直纳闷明明就已经编译过altera的库了,可后来用pll时还是显示未找到文件。感谢及时雨~~~

    能帮到你,挺开心的,哈哈

  2. 写得真好!我一直纳闷明明就已经编译过altera的库了,可后来用pll时还是显示未找到文件。感谢及时雨~~~

  3. @teenagerold

  4. 谢谢博主分享~~~
  5. 引用:jay778778
    谢谢博主的分享,博主这样添加altera库文件以后,ModelSim以后是不是就不需要再次添加了?
    是的,你可以尝试做下看看@jay778778
  6. 谢谢博主的分享,博主这样添加altera库文件以后,ModelSim以后是不是就不需要再次添加了?
  7. 谢谢,分享!