weiqi7777

centos6.5 安装wps linux

0
阅读(67) 评论(0)

wps现在有linux版本,linux里面自带的soffice工具,又感觉比较挫,因此考虑在linux中安装wps工具,来操作excel和work文档。

安装的linux系统为64位系统的centos6.5,因为该系统没有联网,因此是离线安装。    本来以为安装很容易,其实,在安装过程中,遇到了不少坑。特此进行记录。

首先,从wps官网,下载wps rpm包。

https://www.wps.cn/product/wpslinux/

    

此处下载,最好在linux中,用wget命令进行下载。

下载完毕后,如果有联网,直接 yum localinstall 这个下载的安装包就可以了,但是目前的这个版本,11.1.0.8864,需要glibc2.5版本以上。

如果没有联网,就需要自己安装依赖了。

下面说一下,需要安装的依赖:

glibc2.5:这个安装比较容易,按照网上的教程即可。

 

mesa-libGLU-11.0.7-4.el6.x86_64.rpm包,下载地址如下:

https://centos.pkgs.org/6/elrepo-extras-x86_64/mesa-libGLU-8.0.5-1.el6.elrepo.x86_64.rpm.html

 

wps需要新版本的freetype库,centos6.5的freetype库,版本太低,而centos7的freetype库,版本又太高。经测试,freetype-freeworld-2.4.4-6.el6.nux.x86_64.rpm 这个包是可以的。以下是下载链接:

https://centos.pkgs.org/6/nux-dextop-x86_64/freetype-freeworld-2.4.4-6.el6.nux.x86_64.rpm.html

        

包下载完毕后,直接 yum localinstall 安装即可。或者使用rpm2cpio和cpio命令,解压rpm包,把解压出来的库,自行拷贝也可以。

安装完毕后,就可以直接安装wps的rpm包。

也是直接 yum localinstall 该rpm包 或者,将该包解压出来:

rpm2cpio wps.rpm | cpio -ivdm

解压出来的opt/kingsoft/wps-office目录,就是wps工具。

将 opt/Kingsoft/wps-office/office16目录,加入到环境变量PATH中,wps工具就可以使用了。

 

安装完毕之后,就需要安装字体,可以参照如下博文:

https://www.jianshu.com/p/0fd89f4f029d

 

wps安装之后的工具,如下表:

工具名称

说明

et

excel工具

wps

word工具

wpp

ppt工具

wpspdf

pdf工具